PHP Pro Bid

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category User End
  • Assigned To No-one
  • Operating System
  • Severity Medium
  • Priority Very Low
  • Reported Version 7.0
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: PHP Pro Bid
Opened by Vicente - 19.05.2014
Last edited by Mr Super User - 22.05.2014

FS#70 - Postage error when combining multiple purchases

http://screencast.com/t/OFLGmne9pFd

http://screencast.com/t/lRirxIgS4k

http://screencast.com/t/Po3p0GmHkSrQ

I reproduced this bug severl times, please take a look.

To reproduce:
As a seller stablish a flat rate shipping (for example 2 for the first item and 1 for each additional) and put several items on sale.
As a buyer buy multiple quantities from diferent items from the same seller, then combine purchases. Then buy some more items from the same seller, (as if you forgot to buy something, as you didn't paid the first combined invoice you can ask the seller to combine them again.)

Then as a seller combine the new invoice with the already combined one.

Repeat buying and combining to see the bug

That's the steps I did to obtain the bug, I don't know if it can be obtained in other ways, I'm just reporting what I've got, and how I've done to get the bug.

Regards

Closed by  Mr Super User
22.05.2014 06:07
Reason for closing:  Fixed
Admin
Mr Super User commented on 19.05.2014 17:00

This is not a bug, basically you need to click on the "update values" to get the actual postage cost in the postage field when editing/combining invoices.

Vicente commented on 19.05.2014 17:36

Well I press there and it is not correct under my point of view.

Take a look:

http://screencast.com/t/T2OpSdy8fMb8

I don't know why it's showing 10 but 10 doesn't make any sense, it should be or the new one already updated 20€ or the old one 18€ and when I press update turn into 20€, but 10? why?
As I said the amount is calculated correctly later.

Thanks very much

Vicente commented on 21.05.2014 04:55

take a look on my new comment, I added a video. Thanks

Admin
Mr Super User commented on 22.05.2014 06:07

The issue should now be fixed, please double-check and if it is still not working properly, please re-open this bug report.

Vicente commented on 22.05.2014 09:18

Hi

I tested it twice, now looks like it is working properly.

I'll continue testing during the beta phase, and If I find something wrong I'll report again.

You're doing a nice job, keep it up!

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing