PHP Pro Bid

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category User End
  • Assigned To No-one
  • Operating System
  • Severity Medium
  • Priority Very Low
  • Reported Version 7.0
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: PHP Pro Bid
Opened by Vicente - 18.05.2014
Last edited by Mr Super User - 19.05.2014

FS#56 - "Delete Invoice" option can cause confusions

I sold a product, I deleted invoice using the action pulldown near the item on "My Sales" section before buyer paid the invoice.

I then logged on the buyer account and paid the invoice.

The ressult is that I as a seller cannot see that the item was paid, I also didn't recieve any email saying that the item was paid.

In this case Fraudulent sellers can just sell items and delete invoices, or normal sellers that think the item is not going to be paid by the buyer delete them.

I also saw that I as a seller can still ask for a refund from my account history despite the buyer really paid for the item and I should not be able to ask for a refund.
*(I'm going to open another bug regarding this, becouse it is supposed that I cannot ask for a refund if the item was paid, but I'm looking that I can ask for a refund even if the item was paid to the seller, and that is not correct in my opinion)

I suggest removing the "Delete Invoice" button from the actions pulldown until item is paid and mark as shipped to avoid customers confusions.

Regards

Closed by  Mr Super User
19.05.2014 07:49
Reason for closing:  Not a bug
Admin
Mr Super User commented on 19.05.2014 07:49

The invoice delete option has been there in previous versions as well. If most clients will require this change then we will be looking into removing the deletion options however. Otherwise we might add this as a mod.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing