PHP Pro Bid

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category User End
  • Assigned To
    Mr Super User
  • Operating System
  • Severity Medium
  • Priority Very Low
  • Reported Version 7.8
  • Due in Version 7.10
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: PHP Pro Bid
Opened by Antar - 27.02.2017
Last edited by Mr Super User - 25.10.2017

FS#360 - ISSUE: IMAGE UPLOAD PROCESSING ISSUES – MULTIPLE ISSUES!

1- This can be reproduced by dragging one or more jpeg image(s) and dropping over the select images green button or anywhere near It. The loader will start uploading to images and media at the same time. Image will succeed unless below scenario is true, media will obviously not!

2- Uploading a group of images will fail all together, if one of them happen to be over the upload size limit. Again, all will fail after quite a wait and without any error messages. Example: Maximum image upload is set to 8 MB per image with 12 images being uploaded at once. Image 1,2,3,4,5,6,7,8,9,11,12 are under 8 MB, while image 10 is 15 MB. After waiting for quite some time, the upload failed all together and no warning was displayed on the screen upon return to the station. Repeated the process and same thing happened. The size of the image must be checked prior to wasting server resources and then breaking the code!

3- Another test was done on single files over the upload limit, no warning is being shown on media or images over the limit

4- Media file upload limits not working. Testing was first done with 10 MB mp4 file. Our set limit is 20 MB for each video with 5 allowed for free. The server set limit is 30MB for each upload. The 10 MB file mp4 was taken with a Windows phone. It does not upload and no warning is shown in the listing page. It shows the progress bar then bar disappears and no warning or video uploaded. We used handbrake to bring it down in size and it worked! We tested again with three videos and nothing over 10 MB is uploading. Here is the confirmation on the back end side of our set limits.

5- The order/language of the upload form text is not logical (images and media uploads):
You can upload up to 15 images. Order Arrange images by drag and drop.
(+$0.25 / image)
First 12 uploaded images are free. Additional images are $0.25 per image.

6- We noticed that images are not being renamed on upload. This is not a good practice. Image names should be renamed and optimized. See optimizing issues to follow…

7- Uploaded image increased in file size three folds! We tested an optimized 500KB jpeg (batched with jpeg @ 80% quality in Adobe Fireworks) and downloaded it back to find out the size is now 1.57 MB. How is that possible? The original image was 1900 x 1337 @ 314 dpi (taken with an average consumer grade Olympus camera) and although it was sized down to 1200 x 844 on the server, the file size increased three folds (both files attached). I tested this again with other images, and again the size increased on the server by at least 1MB with each image. Image uploads must have proper optimization done prior to saving on the server. So far, we tested 20 images, 15 had file size increases.

8- Since the optimization on the images are buggy, the listing loaded slowly and large images loaded so slow, like we are back on dial up!

Closed by  Mr Super User
25.10.2017 10:43
Reason for closing:  Implemented
Antar commented on 27.02.2017 08:00

Also, please check the uploaded images exif headers as they are reporting bad headers when checked via an exif reader. Is the upload php script trying to encode the images uploaded to PNG files and thus the file size increase?

I just did another test and a product image that is 350K locally, exploded to 1.5 MB once uploaded.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing