PHP Pro Bid - Bug Tracker http://www.phpprobid.com/dev/bugs/ PHP Pro Bid - Bug Tracker PHP Pro Bid: Recently edited tasks 2017-11-30T00:42:07Z FS#418: Item view counter and total views http://www.phpprobid.com/dev/bugs/index.php?do=details&task_id=418 2017-11-30T00:42:07Z Mr Super User I am often asked if it would not be possible to put a visit counter and monitored in the members area, in the selling section. Is this something planned on your side? I am often asked if it would not be possible to put a visit counter and monitored in the members area, in the selling section. Is this something planned on your side?

]]>
FS#383: Email to Friend Flawed and Possible Spam Tool http://www.phpprobid.com/dev/bugs/index.php?do=details&task_id=383 2017-11-14T07:30:28Z Antar We tested the email listing to a friend feature and it is possible to repeat the same email address hundreds of times in the Email Addresses field and the page will take a while but process all the requests in the form. 1- Same email address was addressed 100 times - Script allowed it to go through and we received 100 emails to same email. Not good!2- Works the same way even if a list of comma delimited emails is pasted there. Not good either! This opens up the server operator to grey and blacklisting when this feature is abused either intentionally or not. It’s like having an open relay! The form should not allow the same email address more than once, it should remove dupes. Also a limit on the number of email addresses allowed, perhaps the easiest fix is a max length on the email addresses field itself. We tested the email listing to a friend feature and it is possible to repeat the same email address hundreds of times in the Email Addresses field and the page will take a while but process all the requests in the form.

1- Same email address was addressed 100 times - Script allowed it to go through and we received 100 emails to same email. Not good!
2- Works the same way even if a list of comma delimited emails is pasted there. Not good either!

This opens up the server operator to grey and blacklisting when this feature is abused either intentionally or not. It’s like having an open relay!

The form should not allow the same email address more than once, it should remove dupes. Also a limit on the number of email addresses allowed, perhaps the easiest fix is a max length on the email addresses field itself.

]]>
FS#359: ISSUE: HTML EDITOR IS NOT RENDERING SOME HTML PROPERLY! http://www.phpprobid.com/dev/bugs/index.php?do=details&task_id=359 2017-11-01T08:19:01Z Antar As mentioned to you in a separate email, custom html pasted in the online html editor does not render certain tags at all, such as line breaks, unordered and ordered lists. Our initial test was from Visual Studio and Dreamweaver html editors. Further testing now confirms that the online html editor is also useless and does not render any kind of lists as well as line breaks. This is simply unacceptable if we are going to charge money for listings. If you look at any listings on marketplaces such as eBay, Amazon, Wayfair, Etsy, Rakuten etc…, the vast majority, if not all of listings utilize disc style lists to display items specs. We cannot ask out users to use special tags that override bootstrap css! We can try something like this in our version, but if we start playing around with our CSS and code at the get go, we will end up with a custom version in a week! @import url(’//netdna.bootstrapcdn.com/bootstrap/3.0.0/css/bootstrap-theme.min.css’);ul {list-style-type: disc !important;padding-left:1em !important;margin-left:1em;} We strongly recommend that you do something about this in your next version and looking forward for your recommendation to fix the online html editor! As mentioned to you in a separate email, custom html pasted in the online html editor does not render certain tags at all, such as line breaks, unordered and ordered lists. Our initial test was from Visual Studio and Dreamweaver html editors. Further testing now confirms that the online html editor is also useless and does not render any kind of lists as well as line breaks. This is simply unacceptable if we are going to charge money for listings. If you look at any listings on marketplaces such as eBay, Amazon, Wayfair, Etsy, Rakuten etc…, the vast majority, if not all of listings utilize disc style lists to display items specs. We cannot ask out users to use special tags that override bootstrap css!

We can try something like this in our version, but if we start playing around with our CSS and code at the get go, we will end up with a custom version in a week!

@import url(’//netdna.bootstrapcdn.com/bootstrap/3.0.0/css/bootstrap-theme.min.css’);
ul {
list-style-type: disc !important;
padding-left:1em !important;
margin-left:1em;
}

We strongly recommend that you do something about this in your next version and looking forward for your recommendation to fix the online html editor!

]]>
FS#370: Custom fields not being searched from main search bar or keywords http://www.phpprobid.com/dev/bugs/index.php?do=details&task_id=370 2017-11-01T07:25:21Z Antar I set up a custom field for books category called ISBN, the field is set to be searchable in the settings and is active. I cannot view the listing by searching that ISBN number in the main site keyword search although it is displayed in the item specs. The only way to search and get a hit from the database from any custom field is to use the side menu and search that specific field! Why are custom fields not searchable from the main site search box? It totally defeats the purpose of having a custom searchable field such as UPC or ISBN. Users who search the website for a book using a UPC or ISBN will not be able to find anything! I set up a custom field for books category called ISBN, the field is set to be searchable in the settings and is active.

I cannot view the listing by searching that ISBN number in the main site keyword search although it is displayed in the item specs.

The only way to search and get a hit from the database from any custom field is to use the side menu and search that specific field!

Why are custom fields not searchable from the main site search box? It totally defeats the purpose of having a custom searchable field such as UPC or ISBN.

Users who search the website for a book using a UPC or ISBN will not be able to find anything!

]]>
FS#394: Language Issue: Login vs. Sign in AND Sign up vs. Register http://www.phpprobid.com/dev/bugs/index.php?do=details&task_id=394 2017-11-01T07:24:59Z Antar The use of the word Sign in and Login AND Sign Up / Register together is very confusing. Let’s stick to one! We use Sign in using FacebookSign in using Google+ The link in the header says “Sign up / Sign in”. This sets the precedence for what to follow. Then the sign in page is somehow titled “login” in the redirect module. http://domain.com/login The button to submit the Sign In form says “Login” where it should actually say “Sign In” and the form should say “If you have an account with us, please sign in” There needs to be uniformity, use let’s use one and stick with it. “Already have an account ? Log in” should be Already have an account ? Sign in” and so on and on...Same with Signing Up “Don’t have an account? To register, please click on the link below.” should say “Don’t have an account? To sign up, please click on the link below.” The use of the word Sign in and Login AND Sign Up / Register together is very confusing. Let’s stick to one!

We use

Sign in using Facebook
Sign in using Google+

The link in the header says “Sign up / Sign in”. This sets the precedence for what to follow.

Then the sign in page is somehow titled “login” in the redirect module. http://domain.com/login

The button to submit the Sign In form says “Login” where it should actually say “Sign In” and the form should say “If you have an account with us, please sign in”

There needs to be uniformity, use let’s use one and stick with it.

“Already have an account ? Log in” should be

Already have an account ? Sign in”

and so on and on...
Same with Signing Up

“Don’t have an account? To register, please click on the link below.” should say

“Don’t have an account? To sign up, please click on the link below.”

]]>
FS#416: Critical Issues with Bulk Lister http://www.phpprobid.com/dev/bugs/index.php?do=details&task_id=416 2017-11-01T07:22:21Z Antar Please confirm and resolve the following as this renders the entire MOD and therefore the entire solution unusable for us at this time. We have custom fields in many categories, example: VIN in cars (required) and ISBN in Books (required). First issue: The sample CSV file downloaded does not have these fields by name, Example: VIN is custom_field_4 and ISB is custom_field_10. Major flaw. How is the customer going to know which is which? It took us ages to realize and map them. Second Issue: The Bulk Lister wants all custom required fields regardless of the Category selected. Example: We are uploading in Art, yet the Bulk Lister is asking for VIN, ISBN etc.. (All Required fields from unrelated Categories). Third Issue: The error generated by the Lister looks like that: ‘VIN’ is required and cannot be empty.‘Mileage (mi)’ is required and cannot be empty. Again, we are uploading in Art where these fields do not apply and most importantly, now the Lister is calling the Custom Fields by name, while in the CSV sample, it is only giving them header values of custom_field_1, custom_field_2, custom_field_3 and so on. Please confirm and resolve the following as this renders the entire MOD and therefore the entire solution unusable for us at this time.

We have custom fields in many categories, example: VIN in cars (required) and ISBN in Books (required).

First issue: The sample CSV file downloaded does not have these fields by name, Example: VIN is custom_field_4 and ISB is custom_field_10. Major flaw. How is the customer going to know which is which? It took us ages to realize and map them.

Second Issue: The Bulk Lister wants all custom required fields regardless of the Category selected. Example: We are uploading in Art, yet the Bulk Lister is asking for VIN, ISBN etc.. (All Required fields from unrelated Categories).

Third Issue: The error generated by the Lister looks like that:

‘VIN’ is required and cannot be empty.
‘Mileage (mi)’ is required and cannot be empty.

Again, we are uploading in Art where these fields do not apply and most importantly, now the Lister is calling the Custom Fields by name, while in the CSV sample, it is only giving them header values of custom_field_1, custom_field_2, custom_field_3 and so on.

]]>
FS#372: Selling tools: Prefilled fields - PayPal payment method error, 7 consecutive pop up error http://www.phpprobid.com/dev/bugs/index.php?do=details&task_id=372 2017-10-31T12:35:34Z Antar User goes to pre-filled fields, selects PayPal as payment method before setting up payment gateway in account section. Pop warning “Warning! This direct payment gateway is currently disabled. To enable it, you will need to set the necessary credentials.” appears 7 consecutive times and user has press OK 7 times to get rid of pop warning. Also, this warning is not intuitive and does not really tell the user what to do. Not meant for average user. Why not tell the user where to find the option and what is needed! User goes to pre-filled fields, selects PayPal as payment method before setting up payment gateway in account section.

Pop warning “Warning! This direct payment gateway is currently disabled. To enable it, you will need to set the necessary credentials.” appears 7 consecutive times and user has press OK 7 times to get rid of pop warning.

Also, this warning is not intuitive and does not really tell the user what to do. Not meant for average user. Why not tell the user where to find the option and what is needed!

]]>
FS#371: Enable Force Payment display issue http://www.phpprobid.com/dev/bugs/index.php?do=details&task_id=371 2017-10-31T12:34:00Z Antar When this setting is enabled in the admin section, only minutes are allowed. If we want to set it up for three days, we enter 4320 minutes. Now when the user sees this on their end, it looks funny and unprofessional. This is what the user see: “If this option is enabled, sales will automatically cancelled unless marked as paid within 4320 minutes.” This needs to have proper conversion on the user’s end, so the user reads something that makes sense. This is like telling someone, see in 1440 minutes instead of saying see you tomorrow. When this setting is enabled in the admin section, only minutes are allowed. If we want to set it up for three days, we enter 4320 minutes. Now when the user sees this on their end, it looks funny and unprofessional. This is what the user see: “If this option is enabled, sales will automatically cancelled unless marked as paid within 4320 minutes.”

This needs to have proper conversion on the user’s end, so the user reads something that makes sense. This is like telling someone, see in 1440 minutes instead of saying see you tomorrow.

]]>
FS#360: ISSUE: IMAGE UPLOAD PROCESSING ISSUES – MULTIPLE ISSUES! http://www.phpprobid.com/dev/bugs/index.php?do=details&task_id=360 2017-10-25T10:43:35Z Antar 1- This can be reproduced by dragging one or more jpeg image(s) and dropping over the select images green button or anywhere near It. The loader will start uploading to images and media at the same time. Image will succeed unless below scenario is true, media will obviously not! 2- Uploading a group of images will fail all together, if one of them happen to be over the upload size limit. Again, all will fail after quite a wait and without any error messages. Example: Maximum image upload is set to 8 MB per image with 12 images being uploaded at once. Image 1,2,3,4,5,6,7,8,9,11,12 are under 8 MB, while image 10 is 15 MB. After waiting for quite some time, the upload failed all together and no warning was displayed on the screen upon return to the station. Repeated the process and same thing happened. The size of the image must be checked prior to wasting server resources and then breaking the code! 3- Another test was done on single files over the upload limit, no warning is being shown on media or images over the limit 4- Media file upload limits not working. Testing was first done with 10 MB mp4 file. Our set limit is 20 MB for each video with 5 allowed for free. The server set limit is 30MB for each upload. The 10 MB file mp4 was taken with a Windows phone. It does not upload and no warning is shown in the listing page. It shows the progress bar then bar disappears and no warning or video uploaded. We used handbrake to bring it down in size and it worked! We tested again with three videos and nothing over 10 MB is uploading. Here is the confirmation on the back end side of our set limits. 5- The order/language of the upload form text is not logical (images and media uploads): You can upload up to 15 images. Order Arrange images by drag and drop.(+$0.25 / image)First 12 uploaded images are free. Additional images are $0.25 per image. 6- We noticed that images are not being renamed on upload. This is not a good practice. Image names should be renamed and optimized. See optimizing issues to follow… 7- Uploaded image increased in file size three folds! We tested an optimized 500KB jpeg (batched with jpeg @ 80% quality in Adobe Fireworks) and downloaded it back to find out the size is now 1.57 MB. How is that possible? The original image was 1900 x 1337 @ 314 dpi (taken with an average consumer grade Olympus camera) and although it was sized down to 1200 x 844 on the server, the file size increased three folds (both files attached). I tested this again with other images, and again the size increased on the server by at least 1MB with each image. Image uploads must have proper optimization done prior to saving on the server. So far, we tested 20 images, 15 had file size increases. 8- Since the optimization on the images are buggy, the listing loaded slowly and large images loaded so slow, like we are back on dial up! 1- This can be reproduced by dragging one or more jpeg image(s) and dropping over the select images green button or anywhere near It. The loader will start uploading to images and media at the same time. Image will succeed unless below scenario is true, media will obviously not!

2- Uploading a group of images will fail all together, if one of them happen to be over the upload size limit. Again, all will fail after quite a wait and without any error messages. Example: Maximum image upload is set to 8 MB per image with 12 images being uploaded at once. Image 1,2,3,4,5,6,7,8,9,11,12 are under 8 MB, while image 10 is 15 MB. After waiting for quite some time, the upload failed all together and no warning was displayed on the screen upon return to the station. Repeated the process and same thing happened. The size of the image must be checked prior to wasting server resources and then breaking the code!

3- Another test was done on single files over the upload limit, no warning is being shown on media or images over the limit

4- Media file upload limits not working. Testing was first done with 10 MB mp4 file. Our set limit is 20 MB for each video with 5 allowed for free. The server set limit is 30MB for each upload. The 10 MB file mp4 was taken with a Windows phone. It does not upload and no warning is shown in the listing page. It shows the progress bar then bar disappears and no warning or video uploaded. We used handbrake to bring it down in size and it worked! We tested again with three videos and nothing over 10 MB is uploading. Here is the confirmation on the back end side of our set limits.

5- The order/language of the upload form text is not logical (images and media uploads):
You can upload up to 15 images. Order Arrange images by drag and drop.
(+$0.25 / image)
First 12 uploaded images are free. Additional images are $0.25 per image.

6- We noticed that images are not being renamed on upload. This is not a good practice. Image names should be renamed and optimized. See optimizing issues to follow…

7- Uploaded image increased in file size three folds! We tested an optimized 500KB jpeg (batched with jpeg @ 80% quality in Adobe Fireworks) and downloaded it back to find out the size is now 1.57 MB. How is that possible? The original image was 1900 x 1337 @ 314 dpi (taken with an average consumer grade Olympus camera) and although it was sized down to 1200 x 844 on the server, the file size increased three folds (both files attached). I tested this again with other images, and again the size increased on the server by at least 1MB with each image. Image uploads must have proper optimization done prior to saving on the server. So far, we tested 20 images, 15 had file size increases.

8- Since the optimization on the images are buggy, the listing loaded slowly and large images loaded so slow, like we are back on dial up!

]]>
FS#384: Account Setting page issue with page title after an edit http://www.phpprobid.com/dev/bugs/index.php?do=details&task_id=384 2017-10-24T10:11:02Z Antar When editing info in account setting page, after submission, the title of the page shown is wrong “Edit User”! When editing info in account setting page, after submission, the title of the page shown is wrong “Edit User”!

]]>